1. Advertising
    y u no do it?

    Advertising (learn more)

    Advertise virtually anything here, with CPM banner ads, CPM email ads and CPC contextual links. You can target relevant areas of the site and show ads based on geographical location of the user if you wish.

    Starts at just $1 per CPM or $0.10 per CPC.

Wordpress Help Needed!

Discussion in 'WordPress' started by ryandaniels2013, Jul 26, 2014.

  1. #1
    my website rightinvestproperty.com is having a problem with posts, when i click on the posts i get the message,
    SEMrush
    You tried going to http://rightinvestproperty.com/how-to-become-a-real-estate-investor/, and it doesn't exist. All is not lost! You can search for what you're looking for.

    404 Error

    This does not occur on all posts, but does for many of them, any ideas?
     
    ryandaniels2013, Jul 26, 2014 IP
    SEMrush
  2. TIEro

    TIEro Active Member

    Messages:
    741
    Likes Received:
    177
    Best Answers:
    5
    Trophy Points:
    70
    #2
    The first thing to do is to go to Settings -> Permalinks. Change it to the default and hit "Save Changes", then change it back to "post name" (or whatever choice you wish to use) and hit "Save Changes" again. This will force an update of all permalink URLs. See if that sorts it. :)
     
    TIEro, Jul 26, 2014 IP
  3. jobsbywork

    jobsbywork Active Member

    Messages:
    126
    Likes Received:
    2
    Best Answers:
    0
    Trophy Points:
    58
    #3
    have you changed any thing in permalinks or you might have deleted that post ?
     
    jobsbywork, Jul 26, 2014 IP
  4. ryandaniels2013

    ryandaniels2013 Greenhorn

    Messages:
    28
    Likes Received:
    3
    Best Answers:
    0
    Trophy Points:
    13
    #4
    I changed permalinks to post name and no i have not deleted any post
     
    ryandaniels2013, Jul 26, 2014 IP
  5. Jameyson MacDonald

    Jameyson MacDonald Well-Known Member

    Messages:
    452
    Likes Received:
    83
    Best Answers:
    3
    Trophy Points:
    115
    #5
    Permalinks... If those posts already existed and you change the way permalinks are displayed, you will get an error when trying to view those old posts. You'll need to manually edit each one and change the link.
     
    Jameyson MacDonald, Jul 26, 2014 IP
  6. ryandaniels2013

    ryandaniels2013 Greenhorn

    Messages:
    28
    Likes Received:
    3
    Best Answers:
    0
    Trophy Points:
    13
    #6
    I changed the permalinks and then added the posts, so not really sure what the problem is??
     
    ryandaniels2013, Jul 26, 2014 IP
  7. TIEro

    TIEro Active Member

    Messages:
    741
    Likes Received:
    177
    Best Answers:
    5
    Trophy Points:
    70
    #7
    Have you gone and done what I suggested above? Switch permalinks, save, switch back?
     
    TIEro, Jul 27, 2014 IP
  8. carrieathomer

    carrieathomer Greenhorn

    Messages:
    108
    Likes Received:
    5
    Best Answers:
    0
    Trophy Points:
    18
    #8
    may you just saved as draft. Publish the post
     
    carrieathomer, Jul 27, 2014 IP
  9. ryandaniels2013

    ryandaniels2013 Greenhorn

    Messages:
    28
    Likes Received:
    3
    Best Answers:
    0
    Trophy Points:
    13
    #9
    I have published it, its just not working??
     
    ryandaniels2013, Jul 28, 2014 IP
  10. ryandaniels2013

    ryandaniels2013 Greenhorn

    Messages:
    28
    Likes Received:
    3
    Best Answers:
    0
    Trophy Points:
    13
    #10
    tried that still not working..
     
    ryandaniels2013, Jul 28, 2014 IP
  11. ladymacbeth9

    ladymacbeth9 Well-Known Member

    Messages:
    81
    Likes Received:
    14
    Best Answers:
    2
    Trophy Points:
    110
    #11
    You likely have an issue with permalinks. IT sounds to me like you've changed your permalinks to the /%postname%/ but your site won't allow the rewrite. Test that theory by putting your permalinks back to the default numeric value and clicking save. If that's the issue, then the posts will show up.
     
    ladymacbeth9, Jul 28, 2014 IP
  12. ladymacbeth9

    ladymacbeth9 Well-Known Member

    Messages:
    81
    Likes Received:
    14
    Best Answers:
    2
    Trophy Points:
    110
    #12
    Actually from exploring your site. I see just one category doing that. It's not sitewide, so it's not a permalink issue. It looks like there is one category that is playing with you. Can you delete that category, move the posts to another cat temporarily and then remake the category and move the posts. Did you by any chance change a category name after creating the posts or did you make changes in post names in the permalinks on the individual posts? Only real estate investing how-to or beginner items are not showing correctly and there are only four of them doing it.
     
    ladymacbeth9, Jul 28, 2014 IP
  13. ryandaniels2013

    ryandaniels2013 Greenhorn

    Messages:
    28
    Likes Received:
    3
    Best Answers:
    0
    Trophy Points:
    13
    #13
    Yes I changed the name of the post in the permalink.
     
    ryandaniels2013, Jul 28, 2014 IP
  14. ladymacbeth9

    ladymacbeth9 Well-Known Member

    Messages:
    81
    Likes Received:
    14
    Best Answers:
    2
    Trophy Points:
    110
    #14
    That was my second guess. I honestly can't explain how to fix it so your best option will be this. Take the posts that you have. save them on a notepad. Delete the posts. Empty the trash so that they don't rename something heinous to avoid the duplication. Recreate the posts using the exact name that you want in the title and paste in the content and click save. Those posts will be visible.
     
    ladymacbeth9, Jul 28, 2014 IP
  15. ryandaniels2013

    ryandaniels2013 Greenhorn

    Messages:
    28
    Likes Received:
    3
    Best Answers:
    0
    Trophy Points:
    13
    #15
    Ok Thanks everyone for the help! I managed to fix it by changing the permalinks and then updating the posts, Maybe the permalinks were too big or they needed a refresh, but there we go, they are working!!!
     
    ryandaniels2013, Aug 1, 2014 IP