1. Advertising
    y u no do it?

    Advertising (learn more)

    Advertise virtually anything here, with CPM banner ads, CPM email ads and CPC contextual links. You can target relevant areas of the site and show ads based on geographical location of the user if you wish.

    Starts at just $1 per CPM or $0.10 per CPC.

Update Apache from OLD version

Discussion in 'Apache' started by Peque, Dec 4, 2018.

  1. #1
    Hello Forum.
    I have a little issue that really gets me off.
    SEMrush
    I have my website created on Ruby on Rails 1.8 passenger - Developed by another person.
    on Debian6 (And not able to update debian)
    My Issue is that my hosting company only runs HyperV - but they do not support VMware which the VM is original build on.

    My Apache is 2.2.16 with SSL 0.9.8
    I have a certificate that I would like to use to secure our webpage.
    But on qualab.com --> I rated C becarse the SSL is old.
    But I cannot upgrade my Debian since it'll upgrade Ruby On Rails - which require a total redesign of the webpage before upgrading to a newer Debian.
    I would like to upgrade my Apache on the Debian but having issues regarding how to do it - and it seems I cannot find the right command for building the Apache the Debian Way - so it'll use the same dir on my Old Debian
     
    Peque, Dec 4, 2018 IP
    SEMrush
  2. hostechsupport

    hostechsupport Well-Known Member

    Messages:
    337
    Likes Received:
    17
    Best Answers:
    5
    Trophy Points:
    138
    #2
    Have you tried # apt-get update?
    # apt-get upgrade what error are you getting?
     
    hostechsupport, Dec 8, 2018 at 2:42 AM IP
  3. Peque

    Peque Peon

    Messages:
    2
    Likes Received:
    0
    Best Answers:
    0
    Trophy Points:
    1
    #3
    Hi
    I cannot do apt-get update - since this will require a new source - and within this new apt source - I'm getting allso updates for the ruby on rails higher than 1.8 - which require a whoile redisgn of the HTML code of the webpage - crappy design yes - but thats the reality. All RubyOnRails call through HTMÆL is changed - so thats why the redesign.
    The main reason is since Apache 2.2.16 only supports TLSv1 - so my main problem is securing the Apache Server more. I must up and run <2.2.23 for getting the support for oter TLS versions.
     
    Peque, Dec 10, 2018 at 2:24 AM IP
  4. RoseHosting

    RoseHosting Active Member

    Messages:
    198
    Likes Received:
    10
    Best Answers:
    10
    Trophy Points:
    88
    #4
    'apt-get update' doesn't install new versions of the packages. It only updates the package lists for new versions of the packages that need upgrade. Anyway, you can exclude the specific Ruby On Rails package from an update using the following command:
    apt-mark hold package
    Code (markup):
    where 'package' is the actual name of the Ruby On Rails package. Then you can update Apache:
    apt-get install apache2
    Code (markup):
    This command will update Apache to the latest version if it is already installed on the server.
     
    RoseHosting, Dec 11, 2018 at 11:54 PM IP