1. Advertising
    y u no do it?

    Advertising (learn more)

    Advertise virtually anything here, with CPM banner ads, CPM email ads and CPC contextual links. You can target relevant areas of the site and show ads based on geographical location of the user if you wish.

    Starts at just $1 per CPM or $0.10 per CPC.

Bug Undefined property: stdClass::$expires_in | stdClass::$token_type | stdClass::

Discussion in 'Better Analytics' started by Tealk, May 25, 2017.

  1. #1
    Hallo,
    i get the following 3 errors every 2 minutes, how can I stop it?
    SEMrush
    Fehlerinformation
    Undefined property: stdClass::$expires_in - library/DigitalPointBetterAnalytics/Helper/Reporting.php:105
    
    Stapelverfolgung
    #0 /home/www/anzahcraft.de/library/DigitalPointBetterAnalytics/Helper/Reporting.php(105): XenForo_Application::handlePhpError(8, 'Undefined prope...', '/home/www/anzah...', 105, Array)
    #1 /home/www/anzahcraft.de/library/DigitalPointBetterAnalytics/Helper/Reporting.php(368): DigitalPointBetterAnalytics_Helper_Reporting::checkAccessToken()
    #2 /home/www/anzahcraft.de/library/DigitalPointBetterAnalytics/Model/Analytics.php(204): DigitalPointBetterAnalytics_Helper_Reporting->getRealtime('rt:activeUsers', 'rt:pagePath', '-rt:activeUsers', 'rt:pagePath=~/i...')
    #3 /home/www/anzahcraft.de/library/DigitalPointBetterAnalytics/CronEntry/Cron.php(15): DigitalPointBetterAnalytics_Model_Analytics->getRealtimeUsage()
    #4 /home/www/anzahcraft.de/library/XenForo/Model/Cron.php(356): DigitalPointBetterAnalytics_CronEntry_Cron::runVeryOften(Array)
    #5 /home/www/anzahcraft.de/library/XenForo/Deferred/Cron.php(24): XenForo_Model_Cron->runEntry(Array)
    #6 /home/www/anzahcraft.de/library/XenForo/Model/Deferred.php(295): XenForo_Deferred_Cron->execute(Array, Array, 7.6256818771362, '')
    #7 /home/www/anzahcraft.de/library/XenForo/Model/Deferred.php(429): XenForo_Model_Deferred->runDeferred(Array, 7.6256818771362, '', false)
    #8 /home/www/anzahcraft.de/library/XenForo/Model/Deferred.php(374): XenForo_Model_Deferred->_runInternal(Array, 8, '', false)
    #9 /home/www/anzahcraft.de/deferred.php(23): XenForo_Model_Deferred->run(false)
    #10 {main}
    
    Benötigter Status
    Array
    (
         => https://anzahcraft.de/deferred.php
        [_GET] => Array
            (
            )
    
        [_POST] => Array
            (
                [_xfRequestUri] => /admin.php?options/list/xfa_map
                [_xfNoRedirect] => 1
                [_xfToken] => ********
                [_xfResponseType] => json
            )
    
    )
    
    
    Code (markup):

    Fehlerinformation
    Undefined property: stdClass::$token_type - library/DigitalPointBetterAnalytics/Helper/Reporting.php:104
    
    Stapelverfolgung
    #0 /home/www/anzahcraft.de/library/DigitalPointBetterAnalytics/Helper/Reporting.php(104): XenForo_Application::handlePhpError(8, 'Undefined prope...', '/home/www/anzah...', 104, Array)
    #1 /home/www/anzahcraft.de/library/DigitalPointBetterAnalytics/Helper/Reporting.php(368): DigitalPointBetterAnalytics_Helper_Reporting::checkAccessToken()
    #2 /home/www/anzahcraft.de/library/DigitalPointBetterAnalytics/Model/Analytics.php(204): DigitalPointBetterAnalytics_Helper_Reporting->getRealtime('rt:activeUsers', 'rt:pagePath', '-rt:activeUsers', 'rt:pagePath=~/i...')
    #3 /home/www/anzahcraft.de/library/DigitalPointBetterAnalytics/CronEntry/Cron.php(15): DigitalPointBetterAnalytics_Model_Analytics->getRealtimeUsage()
    #4 /home/www/anzahcraft.de/library/XenForo/Model/Cron.php(356): DigitalPointBetterAnalytics_CronEntry_Cron::runVeryOften(Array)
    #5 /home/www/anzahcraft.de/library/XenForo/Deferred/Cron.php(24): XenForo_Model_Cron->runEntry(Array)
    #6 /home/www/anzahcraft.de/library/XenForo/Model/Deferred.php(295): XenForo_Deferred_Cron->execute(Array, Array, 7.6256818771362, '')
    #7 /home/www/anzahcraft.de/library/XenForo/Model/Deferred.php(429): XenForo_Model_Deferred->runDeferred(Array, 7.6256818771362, '', false)
    #8 /home/www/anzahcraft.de/library/XenForo/Model/Deferred.php(374): XenForo_Model_Deferred->_runInternal(Array, 8, '', false)
    #9 /home/www/anzahcraft.de/deferred.php(23): XenForo_Model_Deferred->run(false)
    #10 {main}
    
    Benötigter Status
    Array
    (
         => https://anzahcraft.de/deferred.php
        [_GET] => Array
            (
            )
    
        [_POST] => Array
            (
                [_xfRequestUri] => /admin.php?options/list/xfa_map
                [_xfNoRedirect] => 1
                [_xfToken] => ********
                [_xfResponseType] => json
            )
    
    )
    
    
    Code (markup):

    Fehlerinformation
    Undefined property: stdClass::$access_token - library/DigitalPointBetterAnalytics/Helper/Reporting.php:103
    
    Stapelverfolgung
    #0 /home/www/anzahcraft.de/library/DigitalPointBetterAnalytics/Helper/Reporting.php(103): XenForo_Application::handlePhpError(8, 'Undefined prope...', '/home/www/anzah...', 103, Array)
    #1 /home/www/anzahcraft.de/library/DigitalPointBetterAnalytics/Helper/Reporting.php(368): DigitalPointBetterAnalytics_Helper_Reporting::checkAccessToken()
    #2 /home/www/anzahcraft.de/library/DigitalPointBetterAnalytics/Model/Analytics.php(204): DigitalPointBetterAnalytics_Helper_Reporting->getRealtime('rt:activeUsers', 'rt:pagePath', '-rt:activeUsers', 'rt:pagePath=~/i...')
    #3 /home/www/anzahcraft.de/library/DigitalPointBetterAnalytics/CronEntry/Cron.php(15): DigitalPointBetterAnalytics_Model_Analytics->getRealtimeUsage()
    #4 /home/www/anzahcraft.de/library/XenForo/Model/Cron.php(356): DigitalPointBetterAnalytics_CronEntry_Cron::runVeryOften(Array)
    #5 /home/www/anzahcraft.de/library/XenForo/Deferred/Cron.php(24): XenForo_Model_Cron->runEntry(Array)
    #6 /home/www/anzahcraft.de/library/XenForo/Model/Deferred.php(295): XenForo_Deferred_Cron->execute(Array, Array, 7.6256818771362, '')
    #7 /home/www/anzahcraft.de/library/XenForo/Model/Deferred.php(429): XenForo_Model_Deferred->runDeferred(Array, 7.6256818771362, '', false)
    #8 /home/www/anzahcraft.de/library/XenForo/Model/Deferred.php(374): XenForo_Model_Deferred->_runInternal(Array, 8, '', false)
    #9 /home/www/anzahcraft.de/deferred.php(23): XenForo_Model_Deferred->run(false)
    #10 {main}
    
    Benötigter Status
    Array
    (
         => https://anzahcraft.de/deferred.php
        [_GET] => Array
            (
            )
    
        [_POST] => Array
            (
                [_xfRequestUri] => /admin.php?options/list/xfa_map
                [_xfNoRedirect] => 1
                [_xfToken] => ********
                [_xfResponseType] => json
            )
    
    )
    
    
    Code (markup):
    from yesterday 22:20 Uhr until now
    [​IMG]
     
    Tealk, May 25, 2017 IP
    SEMrush
  2. digitalpoint

    digitalpoint Overlord of no one Staff

    Messages:
    38,199
    Likes Received:
    2,584
    Best Answers:
    457
    Trophy Points:
    710
    Digital Goods:
    29
    #2
    It looks like your setup may have lost it's Google API credentials somehow (maybe they were revoked on the Google Account side or something).

    If you enable XenForo's debug mode, then go to Admin -> Options -> Debug Options, you can remove the contents of the "Analytics Reporting Tokens" setting (just clear it out) and it will reset the credentials and you can link it up again if you wish.
     
    digitalpoint, May 25, 2017 IP
  3. Tealk

    Tealk Member

    Messages:
    3
    Likes Received:
    0
    Best Answers:
    0
    Trophy Points:
    41
    #3
    Thank you, now it run fine again :D
     
    Tealk, May 26, 2017 IP