1. Advertising
    y u no do it?

    Advertising (learn more)

    Advertise virtually anything here, with CPM banner ads, CPM email ads and CPC contextual links. You can target relevant areas of the site and show ads based on geographical location of the user if you wish.

    Starts at just $1 per CPM or $0.10 per CPC.

Transparent image turns white when saved..?

Discussion in 'Photoshop' started by Gatorade, Sep 13, 2007.

  1. #1
    I think I accidentally changed a setting.

    When I create a new transparent image the image goes straight to layer 1 instead of background. When I save or flatten the image it has a white background instead of a transparent like it should.

    Does anyone know what setting I need to fix or what might be wrong?
    SEMrush
     
    Gatorade, Sep 13, 2007 IP
    SEMrush
  2. scoopy82

    scoopy82 Active Member

    Messages:
    838
    Likes Received:
    45
    Best Answers:
    0
    Trophy Points:
    70
    #2
    What type of file are you saving this as ? JPEGs don't do transparent... GIFs and PNGs do. And Image/Mode needs to be set for indexed color... unless you save to some other file format, such as PSD or PNG.
     
    scoopy82, Sep 14, 2007 IP
    Gatorade likes this.
  3. Nora

    Nora Well-Known Member

    Messages:
    2,105
    Likes Received:
    76
    Best Answers:
    0
    Trophy Points:
    140
    #3
    Its probably just what Scooby said. :)
    I have that a lot when I save to jpeg instead of gif..
     
    Nora, Sep 14, 2007 IP
  4. Gatorade

    Gatorade Peon

    Messages:
    2,130
    Likes Received:
    222
    Best Answers:
    0
    Trophy Points:
    0
    #4
    I don't think that's it. When I create a new image it jumps straight to layer 1 instead of background. It used to start as background and then the next layer would be layer 1.

    It also turns the background white before I even save it. There will be no background until I flatten the image and then it adds a white background.
     
    Gatorade, Sep 14, 2007 IP
  5. Barxy

    Barxy Peon

    Messages:
    43
    Likes Received:
    2
    Best Answers:
    0
    Trophy Points:
    0
    #5
    You don't have to flatten the image before you save it do you? Keep layer 1 transparent and build on top of it. Then just save it as a .png . I'm probably talking rubbish though. :)
     
    Barxy, Sep 14, 2007 IP
  6. eruct

    eruct Well-Known Member

    Messages:
    1,189
    Likes Received:
    49
    Best Answers:
    0
    Trophy Points:
    108
    #6
    what are you trying to do with this image?

    if you are saving for web use, you don't have to flatten. just make sure the background layer is turned off before using file> save for web. then select .png or as scoopy said, make sure you are working with index if you need a .jpg.


    all flattening does is reduce file size by combing all layers into one. this also makes the image almost impossible to edit again so you generally want to keep a .psd file too.
     
    eruct, Sep 14, 2007 IP
    Gatorade likes this.
  7. scoopy82

    scoopy82 Active Member

    Messages:
    838
    Likes Received:
    45
    Best Answers:
    0
    Trophy Points:
    70
    #7
    That is the way my PS works. If I create a new image with "Background Contents" set for "White" or "Background Color"... then the first layer is "background". But if I create a new image using "Background Contents: Transparant"... It starts with "Layer 1". Not sure why, but maybe the transparency is considered the background ?

    If I need a separate background layer, I will click on the button in the "Layers Window" (just to left of trash can) to create a new layer and drag that layer down in the "Layers Window" if desired.
     
    scoopy82, Sep 14, 2007 IP
  8. Gatorade

    Gatorade Peon

    Messages:
    2,130
    Likes Received:
    222
    Best Answers:
    0
    Trophy Points:
    0
    #8
    Ok, I understand now. Thanks for your help everyone, you've all been very helpful. :)
     
    Gatorade, Sep 16, 2007 IP
  9. rozehrocks

    rozehrocks Active Member

    Messages:
    311
    Likes Received:
    1
    Best Answers:
    0
    Trophy Points:
    88
    #9
    maybe it's the matte color. I save images using the "Save as Web" you can edit the setting there.

    or it's because you flatten the image.
     
    rozehrocks, Sep 18, 2007 IP
  10. NCMedia

    NCMedia Well-Known Member

    Messages:
    1,829
    Likes Received:
    97
    Best Answers:
    0
    Trophy Points:
    115
    #10
    1. Make a new psd file, drag your logo/pic etc. on layer 1, now disable the view/eyeball on the background layer so you can see the checkered background that photoshop defaults to.

    2. Save for web while the background layer is turned off.

    3. On the right hand side you will see options, make sure you select .gif and make sure you check the box that sais 'transparency". That should be it.

    Good luck to you.
     
    NCMedia, Sep 21, 2007 IP