1. Advertising
    y u no do it?

    Advertising (learn more)

    Advertise virtually anything here, with CPM banner ads, CPM email ads and CPC contextual links. You can target relevant areas of the site and show ads based on geographical location of the user if you wish.

    Starts at just $1 per CPM or $0.10 per CPC.

Sorry, I wasn't able to establish an SMTP connection. - webmail horde

Discussion in 'Site & Server Administration' started by joujoba, Mar 10, 2010.

  1. #1
    hello

    a large numbers of e-mails are not being send to the wanted party:

    Code (Text):
    1. From:       MAILER-DAEMON@XXX-XX-XXX-XX.local
    2. Subject:     failure notice
    3.  
    4. Hi. This is the qmail-send program at XXX-XX-XXX-XX.local.
    5. I'm afraid I wasn't able to deliver your message to the following addresses.
    6. This is a permanent error; I've given up. Sorry it didn't work out.
    7.  
    8. <XXXXX@aol.com>:
    9. Sorry, I wasn't able to establish an SMTP connection. (#4.4.1)
    10. I'm not going to try again; this message has been in the queue too long.
    11.  
    12. --- Below this line is a copy of the message.
    13. .
    14. .
    15. .
    16.  

    I'm desperate and i can;t find a fix!
    please help me.

    information: I have plesk 9.3.0 on a Debian Lenny 32bit. using currently horde latest version and i also have SSH root access.
    joujoba, Mar 10, 2010 IP
  2. RonBrown

    RonBrown Active Member

    Messages:
    911
    Likes Received:
    41
    Best Answers:
    4
    Trophy Points:
    80
    #2
    The chances are the receiving email server is rejecting your email connection because the domain in the email does not resolve to a proper domain, and/or there is no rDNS (there won't be with that address), and various other issues to do with the set-up of the email programme. I know our email servers wouldn't accept your connection to start with, but even if they did would mark all your emails as high probability of being spam and only a tiny percentage would ever be seen by the intended recipient.

    Your from adress, and the address of the email server, makes you look like a spammer and anyone operating a half-decent anti-spam programme will reject your email outright or accept it then either delete it or mark it as "HIGH SPAM".

    You'll need to set your servers email programme up correctly as an email server with a proper rDNS and MX records, and with a real domain. Only then will you have some luck.
    RonBrown, Mar 10, 2010 IP
  3. kailash

    kailash Well-Known Member

    Messages:
    1,244
    Likes Received:
    42
    Best Answers:
    0
    Trophy Points:
    100
    #3
    There is a possibility that the AOL has blocked your server IP address.
    kailash, Mar 10, 2010 IP
  4. joujoba

    joujoba Peon

    Messages:
    100
    Likes Received:
    0
    Best Answers:
    0
    Trophy Points:
    0
    #4
    and how can i do that ronbrown? fixing the rDNS and MX records?
    because only some of the e-mails are arriving while most of them aren't, and this problem is not only aol, but with all webmails. so i think it's something to do with my settings.
    any guides on how to fix them?
    thank you
    joujoba, Mar 10, 2010 IP
  5. RonBrown

    RonBrown Active Member

    Messages:
    911
    Likes Received:
    41
    Best Answers:
    4
    Trophy Points:
    80
    #5
    I'm assuming you're hosting on Linux and my speciality is Windows, but I can give you some general pointers that should apply.

    1. Install a proper email server on your server (or use one you already have access to)
    2. If you install it, make sure you set it up with a proper (real) domain name
    3. Create the appropriate MX and A records for the email server
    4. Ask your host, or if you can do it yourself, set up rDNS (also known as "pointer") records for the email server

    Now, when you send your emails they are being sent from a proper email server, not just the SMTP service on your server. Recipient email servers are more likely to accept your incoming emails.

    You could probably do something similar with the local SMTP service on your server but I'd recommend installing a proper email server - there are bound to be free or cheap ones you can find for your OS.

    I always tell our customers never to send emails using the SMTP service on the servers because as anti-spam systems become more and more prevalent, less and less of the email sent using these systems are likely to be accepted. Always send your emails from a properly configured email server and you have the greatest chance of your emails being delivered.
    RonBrown, Mar 10, 2010 IP
  6. joujoba

    joujoba Peon

    Messages:
    100
    Likes Received:
    0
    Best Answers:
    0
    Trophy Points:
    0
    #6
    thank you very much RonBrown, i'll try to do that specially number 3.
    i already have a proper domain name, and i have horde installed... which i think by a proper email server you mean this

    thanks again, i'll report the result
    joujoba, Mar 10, 2010 IP
  7. joujoba

    joujoba Peon

    Messages:
    100
    Likes Received:
    0
    Best Answers:
    0
    Trophy Points:
    0
    #7
    here's my dns configuration settings in DNS zone.
    what do you suggest? aren't they correctly configured?

    note that i access my mail using webmail.<domain> and not mail.<domain>

    Attached Files:

    joujoba, Mar 11, 2010 IP