1. Advertising
    y u no do it?

    Advertising (learn more)

    Advertise virtually anything here, with CPM banner ads, CPM email ads and CPC contextual links. You can target relevant areas of the site and show ads based on geographical location of the user if you wish.

    Starts at just $1 per CPM or $0.10 per CPC.

Sitegrounds Pushing Trouble

Discussion in 'Site & Server Administration' started by windyman56, Jan 23, 2019.

  1. #1
    Hey all,

    Me and the company I'm working for has run into a bit of a predicament when it comes to pushing one particular website. We've given a client of ours access to the staging site so they can add events and content and push without me or my boss needing to intervene when they need a push. However, there's been an issue as of lately that prevents any kind of push from succeeding.

    A month ago our client came to us to report an issue with the pushing functionality. What had appeared to have happened was that every time a staging site is pushed live, a backup is created in case you need to roll back. Repeated pushes will make these backups (3 gb a piece) take up space in our account and rapidly close in on the 30 gb limit our account has. This prevented the staging site from being pushed live, and caused the push to fail because the backup couldn't be created with such little space remaining. What we ended up having to do was delete the backups that had accumulated, thus allowing the push again.
    SEMrush
    Fast forward to today, the same thing ended up happening as a month or so ago. Client tries to push, can't because disk is too full. So I go in and delete the backups like last time to make space, and it ends up getting stuck yet again at the same backup creation process despite there being ample space on the disk. Something clearly is amiss here, so I immediately went to Siteground support to figure out what was going on. After a lengthy discussion with support, they told me that there was some kind of a plugin issue that was breaking the push function. "tar: wp-content: file changed as we read it" is the error the tech told me he received, which basically says a plugin was supposedly updating information to the live site while the push was occurring, creating a discrepancy in wp-content that cancelled the push.

    I'm not entirely certain what kind of plugin would cause this error and was hoping that some of you would have some more insight as to what could be the culprit, but earlier today I found something that might be a clue. We're using The Events Calendar PRO for our site, and earlier someone seemed to update it on the live site according to the log, which for some reason ended up breaking the site. I disabled the plugin to bring the site back online, thinking that plugin could cause an issue with the pushing, but it ended up not helping matters at all when I disabled it on the staging site and tried to push. So now that I have it narrowed down to a potential plugin issue, has anyone on this forum had issues like this with plugins interfering with staging sites and pushing?

    Plugin list
    Activity Log
    Advanced Custom Fields
    Advanced Post Manager
    Askimet AntiSpam
    Boxzilla
    Cognito Forms
    Custom CSS and Javascript
    Custom Facebook Feed
    Custom Sidebars
    Custom Twitter Feeds
    Custom User Profile Photo
    Download Manager
    Duplicate Post
    Envato Market
    FareHarbor Reservation Calendars
    Featured Video Plus
    Feeder Ninja feeds
    Flickr Badges Widget
    Gameplan- Member
    Gameplan- Portfolio
    Gameplan- Shortcodes
    Gameplan- Tribe- Addons
    Google XML Sitemaps
    Header and Footer Scripts
    Hello Dolly
    Html5 Audio Player
    Instagram Feed
    Instagram Slider Widget
    Jetpack by WordPress.com
    Logooos Wordpress Plugin
    MailChimp for WordPress
    MailChimp for WordPress- Top Bar
    MailChimp User Sync
    ManageWP- Worker
    MOJO Marketplace
    OptinMonster API
    PDF Viewer
    Popup Maker
    Quick Page/Post Redirect Plugin
    SG Optimizer
    Simple Sitemap
    Slider Revolution
    The Events Calendar
    The Events Calendar PRO
    Visual Form Builder
    Widget Shortcode
    WP All Export
    WP Clone by WP Academy
    WP Featherlight
    WP Maintenance Mode
    WP-PageNavi
    WPBakery Page Builder
    WPForms Lite
    WS Custom Login
     
    windyman56, Jan 23, 2019 IP
    SEMrush
  2. webhost.uk.net

    webhost.uk.net Well-Known Member

    Messages:
    293
    Likes Received:
    8
    Best Answers:
    0
    Trophy Points:
    128
    #2
    I think this is something to do with the backup that you tried to delete.
    I found below answer on centOS forum for the error you submitted.
    ===================================================================
    The file was changed by another process whilst the tar command was attempting to read it. You now need to consider:
    1) Will a subsequent backup catch it? You can then decide if the risk of an unbackedup file for a day(?) is worth it.
    2) If this is a fixed point for archive, milestone or distribution then you probably need to redo the archive after stopping anyone/thing from altering the tree.
    ====================================================================
     
    webhost.uk.net, Jan 24, 2019 IP
  3. windyman56

    windyman56 Peon

    Messages:
    3
    Likes Received:
    0
    Best Answers:
    0
    Trophy Points:
    1
    #3
    I actually found out it was one of their plugins, SGOptimizer, that was causing issues with the push. Thanks for the help either way!
     
    windyman56, Feb 5, 2019 IP