1. Advertising
    y u no do it?

    Advertising (learn more)

    Advertise virtually anything here, with CPM banner ads, CPM email ads and CPC contextual links. You can target relevant areas of the site and show ads based on geographical location of the user if you wish.

    Starts at just $1 per CPM or $0.10 per CPC.

Problems getting Apache Webserver and Forward Proxy running

Discussion in 'Apache' started by drew026, Jan 3, 2019.

  1. #1
    Hello all. First off I am a newbie, so the answer my be simple, but 3 days of head butting and I'm at my limit. I am trying to accomplish 2 things. Create a web server, and create a forward proxy. I downloaded Apache to do both of these things. I am working on Ubuntu 18.04 Server, on it's own machine, not a virtualbox. I have a domain name registered as well.

    I'll start with trying to fix the webserver, and see if that alone fixes the problem. NGINX used to work on this machine, so I think Apache should too. I can access the webserver from my local IP, just not externally.

    My first thought could be the problem is ports. My router info is:

    Device : homeserver
    Current Address : 172.16...
    Device Status : Connected DHCP
    Firewall: Enabled
    Address Assignment : Private from pool: 172.16...
    WAN IP Mapping : Router WAN IP address (default)
    Cascaded Router: No

    Firewall Active
    The firewall actively blocks access of unwanted activity from the Internet.

    Current Applications, Pinholes and DMZ Settings: Custom
    Device Allowed Applications Application Type Protocol Port Number(s) Public IP
    homeserver HTTPS Server - tcp 443 64.110...
    HTTP Server - tcp 80 64.110...
    Static IP:172.16.. - - udp 9308 64.110...
    Static IP:172.16... - - tcp 8080 64.110....​

    This is the device details:
    Device Details:
    Name: ubuntu
    • Connection Type: Ethernet
    • IP Address:
      172.16.
    • LAN IP Address Allocation: Static
    • IP Address Type: Private (NAT)
    • Hardware Address:
    • SSID: n/a
    • Status: On
    Allowed Applications Application Type Protocol Port Number(s) Public IP
    HTTPS Server - tcp 443
    64.110.
    HTTP Server - tcp 80
    64.110.​

    So, I think I have a static IP according to my router. And it appears that my ports are listening. (canyouhearme ... disagrees). So my next thought is that IP Address Type: Private (NAT). I have heard that IPs will block those ports, so maybe it's out of my hands and I'm trying to do the impossible. But NGINX used to work on this machine, on this IP, so I believe Apache should work to. So here is some info from the server itself:

    drew@homeserver:/etc/apache2/mods-enabled$ sudo ufw status
    Status: active

    To Action From
    -- ------ ----
    Apache ALLOW Anywhere
    OpenSSH ALLOW Anywhere
    Apache Full ALLOW Anywhere
    80/tcp ALLOW Anywhere
    443/tcp ALLOW Anywhere
    Apache (v6) ALLOW Anywhere (v6)
    OpenSSH (v6) ALLOW Anywhere (v6)
    Apache Full (v6) ALLOW Anywhere (v6)
    80/tcp (v6) ALLOW Anywhere (v6)
    443/tcp (v6) ALLOW Anywhere (v6)​

    probably more rules than needed... the result of headbanging troubleshooting...

    drew@homeserver:/etc/apache2/mods-enabled$ sudo netstat -tulpn
    Active Internet connections (only servers)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 127.0.0.53:53 0.0.0.0:* LISTEN 23806/systemd-resol
    tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN 4651/sshd
    tcp 0 0 127.0.0.1:3306 0.0.0.0:* LISTEN 12394/mysqld
    tcp6 0 0 :::8080 :::* LISTEN 22101/apache2
    tcp6 0 0 :::80 :::* LISTEN 22101/apache2
    tcp6 0 0 :::22 :::* LISTEN 4651/sshd
    udp 0 0 127.0.0.53:53 0.0.0.0:* 23806/systemd-resol
    udp 0 0 172.16.X.X:68 0.0.0.0:* 23780/systemd-netwo​

    Apache seems to be listening tcp6 to port :80, and :8080. Wait... should it be listening on tcp, not tcp6? Could this be why I can access locally, but not externally? Not sure how to change this, must be apache2 config file. Or ports config file. I'll work on those, but if someone can help me at this point, I'd appreciate it. Even if it's to tell me I'm doing something that isn't possible... so I can move on.

    I'll post the config files if I can't figure out the problems there, and also if I do figure it out.
    SEMrush
     
    drew026, Jan 3, 2019 IP
    SEMrush
  2. drew026

    drew026 Peon

    Messages:
    2
    Likes Received:
    0
    Best Answers:
    0
    Trophy Points:
    1
    #2
    Ok, so that should be fine. tcp6 if fails, should default to tcp, if I understand correctly. So moving on..
     
    drew026, Jan 3, 2019 IP
  3. hostechsupport

    hostechsupport Well-Known Member

    Messages:
    411
    Likes Received:
    23
    Best Answers:
    7
    Trophy Points:
    138
    #3
    Seems you are hosting the Server in your own premises (Home) therefore, in such scenario you need to set port forwarding on your router.
     
    hostechsupport, Jan 5, 2019 IP