1. Advertising
    y u no do it?

    Advertising (learn more)

    Advertise virtually anything here, with CPM banner ads, CPM email ads and CPC contextual links. You can target relevant areas of the site and show ads based on geographical location of the user if you wish.

    Starts at just $1 per CPM or $0.10 per CPC.

Migrating Wordpress

Discussion in 'Site & Server Administration' started by amitd, Sep 21, 2017.

  1. #1
    Hi Guys,
    I have a wordpress website which I need to migrate to other hosting.
    I have downloaded the files and uploaded the same on to new hosting.
    Then imported the database to the new server.
    After that changed the SiteURL and Home but still the website is not working properly.
    Could you please help me out?
    Old URL: www .myhomeswa. com.au
    New URL: http :// 27.54.81.161 /~myhomesw/

    Thanks in advance.
    SEMrush
     
    amitd, Sep 21, 2017 IP
    SEMrush
  2. Gosuperb

    Gosuperb Greenhorn

    Messages:
    77
    Likes Received:
    4
    Best Answers:
    1
    Trophy Points:
    23
    #2
    Your hosting provider should help you out with that, for free.
     
    Gosuperb, Sep 21, 2017 IP
    Romanorc likes this.
  3. amitd

    amitd Active Member

    Messages:
    27
    Likes Received:
    0
    Best Answers:
    0
    Trophy Points:
    86
    #3
    Thanks for the response.
    My hosting company says they can't help me and I need to resolve the issue by my own. :-(
     
    amitd, Sep 21, 2017 IP
  4. iHostiGo

    iHostiGo Peon

    Messages:
    19
    Likes Received:
    0
    Best Answers:
    0
    Trophy Points:
    1
    #4
    Is it working now ? because I accessed your url and its working fine. Let me know if you still have any problems with your wordpress website and I will help you
     
    iHostiGo, Sep 21, 2017 IP
  5. amitd

    amitd Active Member

    Messages:
    27
    Likes Received:
    0
    Best Answers:
    0
    Trophy Points:
    86
    #5
    I changed the wp-config file and added the SiteURL and Home there. I don't know why it didn't worked when I have already changed the same from Database > Options> SiteURL and Home

    But now the problem is home page is working but no inner page. :-(
     
    amitd, Sep 22, 2017 IP
  6. iHostiGo

    iHostiGo Peon

    Messages:
    19
    Likes Received:
    0
    Best Answers:
    0
    Trophy Points:
    1
    #6
    Okay i can help you with this, do you have Skype ? so i could guide you through the steps.
     
    Last edited: Sep 22, 2017
    iHostiGo, Sep 22, 2017 IP
  7. Frost1

    Frost1 Well-Known Member

    Messages:
    519
    Likes Received:
    23
    Best Answers:
    7
    Trophy Points:
    115
    #7
    Seems like you got the problem resolved because it works for me now. It's just loading a post page is really slow.
     
    Frost1, Sep 22, 2017 IP
  8. iHostiGo

    iHostiGo Peon

    Messages:
    19
    Likes Received:
    0
    Best Answers:
    0
    Trophy Points:
    1
    #8
    Homepage is working only the inner pages aren't.
     
    iHostiGo, Sep 22, 2017 IP
  9. amitd

    amitd Active Member

    Messages:
    27
    Likes Received:
    0
    Best Answers:
    0
    Trophy Points:
    86
    #9
    Thank you. Already PM you.
     
    amitd, Sep 22, 2017 IP
  10. amitd

    amitd Active Member

    Messages:
    27
    Likes Received:
    0
    Best Answers:
    0
    Trophy Points:
    86
    #10
    Only the home page is working.
    I tried to change the Permalink but I am not able to access wp-admin.
     
    amitd, Sep 22, 2017 IP
  11. PoPSiCLe

    PoPSiCLe Illustrious Member

    Messages:
    4,626
    Likes Received:
    719
    Best Answers:
    151
    Trophy Points:
    420
    #11
    Seems to be working now, so I guess you got it fixed
     
    PoPSiCLe, Sep 22, 2017 IP
  12. amitd

    amitd Active Member

    Messages:
    27
    Likes Received:
    0
    Best Answers:
    0
    Trophy Points:
    86
    #12
    Only Home apge working not the inner pages.
     
    amitd, Sep 22, 2017 IP
  13. PoPSiCLe

    PoPSiCLe Illustrious Member

    Messages:
    4,626
    Likes Received:
    719
    Best Answers:
    151
    Trophy Points:
    420
    #13
    Define "inner pages" - I went to subpages just fine
     
    PoPSiCLe, Sep 22, 2017 IP
  14. PoPSiCLe

    PoPSiCLe Illustrious Member

    Messages:
    4,626
    Likes Received:
    719
    Best Answers:
    151
    Trophy Points:
    420
    #14
    Ah, right, helps to re-read. I did of course not test the IP-address. Yeah, I see the problem. Sure your .htaccess got transferred over as well, to the new host?
     
    PoPSiCLe, Sep 23, 2017 IP
  15. amitd

    amitd Active Member

    Messages:
    27
    Likes Received:
    0
    Best Answers:
    0
    Trophy Points:
    86
    #15
    Yes, Below is the content of htaccess file:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress
    Redirect 301 /admin /wp-admin
    # BEGIN W3TC Page Cache core
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{HTTP_COOKIE} w3tc_preview [NC]
    RewriteRule .* - [E=W3TC_PREVIEW:_preview]
    RewriteCond %{REQUEST_METHOD} !=POST
    RewriteCond %{QUERY_STRING} =""
    RewriteCond %{REQUEST_URI} \/$
    RewriteCond %{HTTP_COOKIE} !(comment_author|wp\-postpass|w3tc_logged_out|wordpress_logged_in|wptouch_switch_toggle) [NC]
    RewriteCond "%{DOCUMENT_ROOT}/wp-content/uploads/cache/page_enhanced/%{HTTP_HOST}/%{REQUEST_URI}/_index%{ENV:W3TC_PREVIEW}.html" -F
    RewriteRule .* "/wp-content/uploads/cache/page_enhanced/%{HTTP_HOST}/%{REQUEST_URI}/_index%{ENV:W3TC_PREVIEW}.html" [L]
    </IfModule>
    # END W3TC Page Cache core
     
    amitd, Sep 23, 2017 IP
  16. rebuildwebsite

    rebuildwebsite Peon

    Messages:
    8
    Likes Received:
    0
    Best Answers:
    0
    Trophy Points:
    1
    #16
    go to wp-admin>settings>general change the url on 1st and 2nd box, the one who show the url name (even if its look correct just press the button to update again), and then go to permalink and press the button again, hope its work

    update: seem u using cache (i can see from the htaccess file) try to clear it, maybe that is the problem, your page still on cache
     
    rebuildwebsite, Nov 10, 2017 IP
  17. anuradhan

    anuradhan Active Member

    Messages:
    371
    Likes Received:
    1
    Best Answers:
    0
    Trophy Points:
    65
    #17
    rename cache plugin folder in wp-plugins. that should fix the problem. btw, that plugin will be disabled. so backup and then do.
     
    anuradhan, Nov 14, 2017 IP
  18. EuropeanNetworks

    EuropeanNetworks Peon

    Messages:
    13
    Likes Received:
    1
    Best Answers:
    0
    Trophy Points:
    3
    #18
    When you are migrating account from the domain (***.tld) to subfolder (***.com/username) you should change old urls in many places, not simply changing url in /wp-admin/

    How to do this?

    Run queries in mysql (ex. phpmyadmin):

    UPDATE wp_options SET option_value = replace(option_value, 'http://www.oldurl', 'http://www.newurl') WHERE option_name = 'home' OR option_name = 'siteurl';
    
    UPDATE wp_posts SET guid = replace(guid, 'http://www.oldurl','http://www.newurl');
    
    UPDATE wp_posts SET post_content = replace(post_content, 'http://www.oldurl', 'http://www.newurl');
    
    UPDATE wp_postmeta SET meta_value = replace(meta_value,'http://www.oldurl','http://www.newurl');
    Code (markup):
     
    EuropeanNetworks, Jun 3, 2018 IP
  19. Cameron Fillers

    Cameron Fillers Greenhorn

    Messages:
    18
    Likes Received:
    2
    Best Answers:
    0
    Trophy Points:
    23
    #19
    It sounds like you did not transfer your .htaccess file. As the .htaccess file is a hidden file, you may have missed it during the migration. Simply create a file using file manager, or a ftp program (or vi if you have shell access) and add the following

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress
    Code (markup):
    You may be missing additional information if you have a caching plugin enabled, but this should be enough information to verify that your internal pages are now working.

    Save it, and make sure the file is owned by the correct user:group, and give it a whirl
     
    Cameron Fillers, Jun 18, 2018 IP