1. Advertising
    y u no do it?

    Advertising (learn more)

    Advertise virtually anything here, with CPM banner ads, CPM email ads and CPC contextual links. You can target relevant areas of the site and show ads based on geographical location of the user if you wish.

    Starts at just $1 per CPM or $0.10 per CPC.

list-style-type:none ignored in slider menu - HELP!

Discussion in 'CSS' started by jtpratt, Aug 14, 2009.

  1. #1
    I installed a slider menu here:
    http://www.blogspot.moments-preserved.com/?page_id=43

    I have html like this:
    
    <div id="imageMenu">
    			<ul>
    				<!-- THESE ARE THE LINKS YOU GO TO WHEN YOU CLICK ON A SLIDING DOOR IMAGE-->
    				<!-- change the href to look like this: <a href="yourlink.com">     -->
    				<li class="bk1"><a href="/edit-with-category-or-page">Category 1</a></li>
    				<li class="bk2"><a href="/edit-with-category-or-page">Category 2</a></li>
    				<li class="bk3"><a href="/edit-with-category-or-page">Category 3</a></li>
    				<li class="bk4"><a href="/edit-with-category-or-page">Category 4</a></li>
    				<li class="bk5"><a href="/edit-with-category-or-page">Category 5</a></li>
    				<li class="bk6"><a href="/edit-with-category-or-page">Category 6</a></li>
    				<li class="bk7"><a href="/edit-with-category-or-page">Category 7</a></li>
    			</ul>
    			</div>
    
    Code (markup):
    the container of course is "imageMenu", this is the CSS that should make the bullets go away:

    #imageMenu ul {
    list-style: none;
    margin: 0px;
    display: block;
    height: 440px;
    padding: 0;
    }
    SEMrush
    #imageMenu ul li {
    float: left;
    border-bottom-style: solid;
    border-bottom-width: 1px;
    padding-bottom: 12px;
    padding-top: 12px;
    list-style-type: none;
    }

    you see I have both list-style: none; and list-style-type: none; in the other.

    I can actually use the firebug extension in firefox and show that the #imageMenu css property is listing "list-style-type: none;" properly for the li's - and yet both Firefox and IE on both Linux and Windows ignore that declaration (even with !important). I don't get it, the exact same menu works perfectly on another site.

    I have reverted to the default wordpress theme and disabled ALL plugins and the problem still exists. view the source of the page to get the CSS URL's if you want to check for anything canceling something out (if there was I couldn't see it).

    ANY help would be GREATLY appreciated - I've tried everything with these to get the list styles to go away on the li's.
     
    jtpratt, Aug 14, 2009 IP
    SEMrush
  2. Love*

    Love* Well-Known Member

    Messages:
    1,739
    Likes Received:
    51
    Best Answers:
    0
    Trophy Points:
    165
    Digital Goods:
    1
    #2
    Try adding this to your stylesheet instead, as a shortcut method to something that will surely work..

    .bk1 li, .bk2 li, .bk3 li, .bk4 li, .bk5 li, .bk6 li, .bk7 li {
    list-style-type: none;
    }
    HTML:
     
    Love*, Aug 14, 2009 IP
  3. Romanos

    Romanos Well-Known Member

    Messages:
    1,062
    Likes Received:
    45
    Best Answers:
    0
    Trophy Points:
    165
    #3
    It's from style.css from the theme.

    .Post ul li
    {
      padding:0px 0 0px 13px;
    [B]  background-image: url(‘images/PostBullets.png');[/B]
      background-repeat:no-repeat;
      margin:0.5em 0 0.5em 0;
      line-height:1.2em;
    }
    
    Code (markup):
     
    Romanos, Aug 15, 2009 IP
  4. c4gamerz

    c4gamerz Well-Known Member

    Messages:
    294
    Likes Received:
    4
    Best Answers:
    0
    Trophy Points:
    110
    #4
    Yes Romanos is right, just remove

    ;)
     
    c4gamerz, Aug 15, 2009 IP
  5. jtpratt

    jtpratt Well-Known Member

    Messages:
    170
    Likes Received:
    3
    Best Answers:
    0
    Trophy Points:
    123
    #5
    thank you, thank you! This absolutely fixed it!
     
    jtpratt, Aug 15, 2009 IP