1. Advertising
    y u no do it?

    Advertising (learn more)

    Advertise virtually anything here, with CPM banner ads, CPM email ads and CPC contextual links. You can target relevant areas of the site and show ads based on geographical location of the user if you wish.

    Starts at just $1 per CPM or $0.10 per CPC.

Links not working in wordpress posts, why?

Discussion in 'WordPress' started by crumblepie, Oct 4, 2011.

  1. #1
    Please have a look at my wordpress post here. The "Read More" text is supposed to be a link. I am having the same problem for all posts. Links are not showing up properly.

    Although the link displays properly in wp-admin, the blog itself is outputting it as normal text rather than a link.

    I can't figure out why, any ideas???? :confused::(
    SEMrush
     
    crumblepie, Oct 4, 2011 IP
    SEMrush
  2. Yuuko008

    Yuuko008 Member

    Messages:
    682
    Likes Received:
    11
    Best Answers:
    0
    Trophy Points:
    33
    #2
    go to your wp-admin>Appearance>editor>single.php (it's single.php most of the time) and see if the Read more is wrapped by something like <a href="<?php the_permalink(); ?>">Read More</a>

    Hope this helps =)
     
    Yuuko008, Oct 4, 2011 IP
  3. seo.geek1

    seo.geek1 Peon

    Messages:
    87
    Likes Received:
    1
    Best Answers:
    0
    Trophy Points:
    0
    #3
    Hey buddy, you just need to insert tag where you want your read more link to be displayed. you can find this option just above the content box in wordpress, while posting a blog..
     
    seo.geek1, Oct 5, 2011 IP
  4. crumblepie

    crumblepie Well-Known Member

    Messages:
    2,613
    Likes Received:
    42
    Best Answers:
    0
    Trophy Points:
    160
    #4
    Thanks for the quick response Yuuko & seogeek, I appreciate it... but my problem remains. The Read More isn't a "read more" - what I mean is, it's a normal link and I just put the text anchor as Read More.
     
    crumblepie, Oct 5, 2011 IP
  5. Yuuko008

    Yuuko008 Member

    Messages:
    682
    Likes Received:
    11
    Best Answers:
    0
    Trophy Points:
    33
    #5
    Please PM me more about the issue. If you can give wp-admin access so I can fix it inside. Let me know ok. I will be happy to help =)
     
    Yuuko008, Oct 5, 2011 IP
    crumblepie likes this.
  6. otshare

    otshare Peon

    Messages:
    70
    Likes Received:
    3
    Best Answers:
    0
    Trophy Points:
    0
    #6
    Strange, it should be working at least when you insert MORE tag from post editing window. Are you sure you are inserting the mroe tag from the Post Editing Window (Wp-Admin)? There is an option where you can ADD the MORE link. It is called "Insert More tag". You can insert it in any place in your post when you are in editing mode.

    Just press that option or press "Alt+Shift+T".

    Another suggestion is - try with another wordpress theme....and see if that too behave the same way.
     
    otshare, Oct 6, 2011 IP
    crumblepie likes this.
  7. seo.geek1

    seo.geek1 Peon

    Messages:
    87
    Likes Received:
    1
    Best Answers:
    0
    Trophy Points:
    0
    #7
    Buddy you just need to insert tag where you need to put read more tag, dont write read more at the end of content.
     
    seo.geek1, Oct 6, 2011 IP
    crumblepie likes this.
  8. crumblepie

    crumblepie Well-Known Member

    Messages:
    2,613
    Likes Received:
    42
    Best Answers:
    0
    Trophy Points:
    160
    #8
    I fixed it, thanks for all your support guys and gals :) Thank you so much. I got it fixed by adding <div class="the_content"><?php the_content(); ?></div> rather than the code for the excerpt. It wasn't a Read More issue.. that was just the text anchor I used which led to a lot of confusion in this thread.. sorry about that! I changed the Reads Mores to View Tutorials now lol. Reps on the way, thanks once again! Ta!
     
    crumblepie, Oct 6, 2011 IP