1. Advertising
    y u no do it?

    Advertising (learn more)

    Advertise virtually anything here, with CPM banner ads, CPM email ads and CPC contextual links. You can target relevant areas of the site and show ads based on geographical location of the user if you wish.

    Starts at just $1 per CPM or $0.10 per CPC.

I have error secure apache on Digital Ocean?

Discussion in 'Apache' started by mstdmstd, Nov 17, 2018.

  1. #1
    Hello,
    I want to set https for my hosting on ubuntu 18 under Digital Ocean as it is written here:
    https://www.digitalocean.com/community/tutorials/how-to-secure-apache-with-let-s-encrypt-on-ubuntu-18-04

    But I had problems with ufw settings:
    # sudo ufw status
    Status: inactive
    root@nsn-do-lamp:/etc/apache2/sites-available# sudo ufw allow 'Apache'
    Rules updated
    Rules updated (v6)
    root@nsn-do-lamp:/etc/apache2/sites-available# sudo ufw status
    Status: inactive
    root@nsn-do-lamp:/etc/apache2/sites-available# sudo systemctl reload apache2
    root@nsn-do-lamp:/etc/apache2/sites-available# sudo ufw status
    Status: inactive
    root@nsn-do-lamp:/etc/apache2/sites-available# sudo ufw allow 'Apache Full'
    Skipping adding existing rule
    Skipping adding existing rule (v6)
    root@nsn-do-lamp:/etc/apache2/sites-available# sudo ufw delete allow 'Apache'
    Rules updated
    Rules updated (v6)
    root@nsn-do-lamp:/etc/apache2/sites-available# sudo ufw status
    Status: inactive
    Code (markup):
    I see that status is inactive.


    I tried to make :
    
    # sudo ufw app list
    Available applications:
    Apache
    Apache Full
    Apache Secure
    OpenSSH
    root@nsn-do-lamp:/etc/apache2/sites-available# sudo ufw allow 'Apache'
    Rules updated
    Rules updated (v6)
    root@nsn-do-lamp:/etc/apache2/sites-available# sudo ufw status
    Status: inactive
    
    Code (markup):
    I think this error is critical and did not proceed with next commands. Why error and how to fix it ?

    Thanks!
    SEMrush
     
    Solved! View solution.
    mstdmstd, Nov 17, 2018 IP
    SEMrush
  2. #2
    Hello,
    Have you tried with sudo ufw enable command?
     
    hostechsupport, Nov 20, 2018 IP
  3. hostechsupport

    hostechsupport Well-Known Member

    Messages:
    411
    Likes Received:
    23
    Best Answers:
    7
    Trophy Points:
    138
    #3
    Thanks for the Appreciation @mstdmstd :) Will be glad to assist you further too.
     
    hostechsupport, Nov 21, 2018 IP