1. Advertising
    y u no do it?

    Advertising (learn more)

    Advertise virtually anything here, with CPM banner ads, CPM email ads and CPC contextual links. You can target relevant areas of the site and show ads based on geographical location of the user if you wish.

    Starts at just $1 per CPM or $0.10 per CPC.

I broke my forum please help

Discussion in 'Forum Management' started by BILZ, Jul 14, 2006.

  1. #1
    Somehow i broke my forum. I was installing a few mods and somehow broke it. Here is the error message i get:
    SEMrush
    http://www.natschat.com/forum/

    Im not a programmer so im pretty lost with it right now. I appreciate any help you can provide. Thanks.
     
    BILZ, Jul 14, 2006 IP
    SEMrush
  2. sandossu

    sandossu Guest

    Messages:
    2,274
    Likes Received:
    88
    Best Answers:
    0
    Trophy Points:
    0
    #2
    open /home/natschat/public_html/forum/Sources/Subs.php
    and look at the lines 1852 and 1883
    there has to be something like this:
    theme_seocopyright() {
    code
    }

    copy the two codes here, including theme_seocopyright() {
    }
     
    sandossu, Jul 14, 2006 IP
  3. BILZ

    BILZ Peon

    Messages:
    1,515
    Likes Received:
    62
    Best Answers:
    0
    Trophy Points:
    0
    #3
    What program should i use to open the php file? I have been using windows notepad but that doesnt tell me the line number. Thanks for your help in advance.
     
    BILZ, Jul 14, 2006 IP
  4. sandossu

    sandossu Guest

    Messages:
    2,274
    Likes Received:
    88
    Best Answers:
    0
    Trophy Points:
    0
    #4
    i use macromedia dreamweaver.
    but you could use notepad and search for theme_seocopyright()
     
    sandossu, Jul 14, 2006 IP
  5. BILZ

    BILZ Peon

    Messages:
    1,515
    Likes Received:
    62
    Best Answers:
    0
    Trophy Points:
    0
    #5
    i am just pasting a chunk of the code that appears to have those words within it.

     
    BILZ, Jul 14, 2006 IP
  6. sandossu

    sandossu Guest

    Messages:
    2,274
    Likes Received:
    88
    Best Answers:
    0
    Trophy Points:
    0
    #6
    you have to delete this
    // Show the SMFSEO copyright...
    function theme_seocopyright($get_it = false)
    {
    global $forum_seocopyright, $context, $boardurl, $forum_version, $txt;
    static $foundseo = false;
    
    // Meaning, this is the footer checking in..
    if ($get_it === true)
    return $foundseo;
    
    echo '
    <span class="smalltext" style="display: inline; visibility: visible; font-family: Verdana, Arial, sans-serif;">';
    
    if ($get_it == 'none')
    {
    $foundseo = true;
    echo '
    The administrator doesn\'t want a copyright notice saying this software is copyright 2006 by <a href="http://www.smfseo.org/" target="_blank">SMFSEO.org</a>, funded by a <a href="http://www.mortgagesearchlive.com/">mortgage</a> broker and implemented by the <a href="http://mytreo.net/">treo</a> smartphone guy, so the forum will honor this request.';
    }
    // If it's in the seo copyright, and we are outputting it... it's been found.
    elseif ((strpos($forum_seocopyright, '<a href="http://www.mortgagesearchlive.com/">mortgage</a>') !== false || strpos($forum_seocopyright, '<a href="http://www.mortgagesearchlive.com/" target="_blank">mortgage</a>') !== false) && (strpos($forum_seocopyright, '<a href="http://mytreo.net/">treo</a>') !== false || strpos($forum_seocopyright, '<a href="http://mytreo.net/" target="_blank">treo</a>') !== false))
    {
    $foundseo = true;
    echo $forum_seocopyright;
    }
    
    echo '
    </span>';
    }
     
    sandossu, Jul 15, 2006 IP
    BILZ likes this.
  7. BILZ

    BILZ Peon

    Messages:
    1,515
    Likes Received:
    62
    Best Answers:
    0
    Trophy Points:
    0
    #7
    BILZ, Jul 16, 2006 IP
  8. sandossu

    sandossu Guest

    Messages:
    2,274
    Likes Received:
    88
    Best Answers:
    0
    Trophy Points:
    0
    #8
    i don`t know the problem. when i first visited the forum, it worked. i refreshed the page and got some error, i refreshed again and see the page blank. i`m sorry i have`t copied the errors so i can see what are them about :(
     
    sandossu, Jul 16, 2006 IP
  9. stdio

    stdio Peon

    Messages:
    467
    Likes Received:
    10
    Best Answers:
    0
    Trophy Points:
    0
    #9
    I am using Notepad++. It shows the line numbers...and much more. Hope this helps.

    Regards.
     
    stdio, Jul 16, 2006 IP
  10. sandossu

    sandossu Guest

    Messages:
    2,274
    Likes Received:
    88
    Best Answers:
    0
    Trophy Points:
    0
    #10
    what does that do with this thread ?
     
    sandossu, Jul 16, 2006 IP
  11. stdio

    stdio Peon

    Messages:
    467
    Likes Received:
    10
    Best Answers:
    0
    Trophy Points:
    0
    #11
    Geez.:confused:
     
    stdio, Jul 16, 2006 IP
  12. sandossu

    sandossu Guest

    Messages:
    2,274
    Likes Received:
    88
    Best Answers:
    0
    Trophy Points:
    0
    #12
    i`m sorry :D
     
    sandossu, Jul 16, 2006 IP
  13. -Abhishek-

    -Abhishek- Regaining my Momentum!

    Messages:
    2,109
    Likes Received:
    302
    Best Answers:
    0
    Trophy Points:
    0
    #13
    I get this when I go to your boards,
    Sorry, the SMFSEO copyright must be in the template.
    Fix it ASAP, as your forum appears to be in it's initial stage and this will only give a bad impression about the boards!
     
    -Abhishek-, Jul 16, 2006 IP
  14. sandossu

    sandossu Guest

    Messages:
    2,274
    Likes Received:
    88
    Best Answers:
    0
    Trophy Points:
    0
    #14
    you should have a programmer have a closer look at your forum ;)
     
    sandossu, Jul 16, 2006 IP
  15. BILZ

    BILZ Peon

    Messages:
    1,515
    Likes Received:
    62
    Best Answers:
    0
    Trophy Points:
    0
    #15
    Aaargh. Any programmers here want to take a look into my forums? I cant pay ya much, but ill definitely sing your praises around the DP forums.
     
    BILZ, Jul 16, 2006 IP
  16. BILZ

    BILZ Peon

    Messages:
    1,515
    Likes Received:
    62
    Best Answers:
    0
    Trophy Points:
    0
    #16
    Woohoo i fixed it!!!! I replaced most of the files with the default files and things appear to be working now. Thanks to everyone who tried to help. Thank god i got it working again, that was driving me nuts. :)
     
    BILZ, Jul 16, 2006 IP
  17. sandossu

    sandossu Guest

    Messages:
    2,274
    Likes Received:
    88
    Best Answers:
    0
    Trophy Points:
    0
    #17
    glad you managed to fix it ;)
     
    sandossu, Jul 17, 2006 IP