1. Advertising
    y u no do it?

    Advertising (learn more)

    Advertise virtually anything here, with CPM banner ads, CPM email ads and CPC contextual links. You can target relevant areas of the site and show ads based on geographical location of the user if you wish.

    Starts at just $1 per CPM or $0.10 per CPC.

How to remove index.php from the URL of my wordpress blog?

Discussion in 'WordPress' started by ready2work, Oct 1, 2007.

  1. #1
    Recently started my website / blog.
    SEMrush
    I tried configuring the Permalinks option in the wordpress admin. Without the index.php in the URL, it is not working. Why?

    The custom option in Permalinks has to be /index.php/%post_name%/ to work. With this option the URL becomes something like this...

    http://consumer-product-review.net/index.php/iphone-technological-“magic-touch”-from-apple/

    What should I do to remove the index.php from the URL?

    Any suggestions from the experts out there?
     
    ready2work, Oct 1, 2007 IP
    SEMrush
  2. mdvaldosta

    mdvaldosta Peon

    Messages:
    4,079
    Likes Received:
    362
    Best Answers:
    0
    Trophy Points:
    0
    #2
    Change it from /index.php/%post_name%/ to /%post_name%/
     
    mdvaldosta, Oct 1, 2007 IP
  3. Lordy

    Lordy Peon

    Messages:
    1,644
    Likes Received:
    29
    Best Answers:
    0
    Trophy Points:
    0
    #3
    i think he's saying that he tried that and it doesnt work.

    what exactly do you put in for the permalinks?
     
    Lordy, Oct 1, 2007 IP
  4. mdvaldosta

    mdvaldosta Peon

    Messages:
    4,079
    Likes Received:
    362
    Best Answers:
    0
    Trophy Points:
    0
    #4
    Make sure the .htaccess is writeable or add the code they ask you to after you change the permalink structure.
     
    mdvaldosta, Oct 1, 2007 IP
  5. ready2work

    ready2work Guest

    Best Answers:
    0
    #5
    I used the custom option and used /index.php/%post_name%/ in it.
     
    ready2work, Oct 1, 2007 IP
  6. ready2work

    ready2work Guest

    Best Answers:
    0
    #6
    Without index.php the link doesn't work.
     
    ready2work, Oct 1, 2007 IP
  7. ready2work

    ready2work Guest

    Best Answers:
    0
    #7
    .htaccess is writable. Is there anything that I should alter in that file?
     
    ready2work, Oct 1, 2007 IP
  8. Emperor

    Emperor Guest

    Messages:
    4,822
    Likes Received:
    180
    Best Answers:
    0
    Trophy Points:
    0
    #8
    You must be doing something wrong. Either your .htaccess isn't correct or it doesn't have write permission.

    Seriously the best thing for you to do is search google for help. This is very well documented so you'll solve the problem kicker that way.
     
    Emperor, Oct 1, 2007 IP
  9. ready2work

    ready2work Guest

    Best Answers:
    0
    #9
    Is 644 permission is OK for .htaccess?
     
    ready2work, Oct 1, 2007 IP
  10. ready2work

    ready2work Guest

    Best Answers:
    0
    #10
    Tried changing the permission of .htaccess to 666....still not working.
     
    ready2work, Oct 1, 2007 IP
  11. Emperor

    Emperor Guest

    Messages:
    4,822
    Likes Received:
    180
    Best Answers:
    0
    Trophy Points:
    0
    #11
    Try 755, if that doesn't work try 777... ;)

    Edit: I just checked mine and it's 644, so there must be another problem.

    Tell us what you have written on your .htaccess file...
     
    Emperor, Oct 1, 2007 IP
  12. ready2work

    ready2work Guest

    Best Answers:
    0
    #12
    I hv not written anything in .htaccess file. It has the default content only. Should I add anything in that?
     
    ready2work, Oct 1, 2007 IP
  13. ready2work

    ready2work Guest

    Best Answers:
    0
    #13
    # -FrontPage-
    IndexIgnore .htaccess */.??* *~ *# */HEADER* */README* */_vti*
    <Limit GET POST>
    order deny,allow
    deny from all
    allow from all
    </Limit>
    <Limit PUT DELETE>
    order deny,allow
    deny from all
    </Limit>
    AuthName consumer-product-review.net
    AuthUserFile /home/consumer/public_html/_vti_pvt/service.pwd
    AuthGroupFile /home/consumer/public_html/_vti_pvt/service.grp
    =============

    This is the content of htaccess.
     
    ready2work, Oct 1, 2007 IP
  14. mdvaldosta

    mdvaldosta Peon

    Messages:
    4,079
    Likes Received:
    362
    Best Answers:
    0
    Trophy Points:
    0
    #14
    There's nothing in the from Wordpress. Make sure your .htaccess is writeable and you update your permalink structure.
     
    mdvaldosta, Oct 1, 2007 IP
  15. Emperor

    Emperor Guest

    Messages:
    4,822
    Likes Received:
    180
    Best Answers:
    0
    Trophy Points:
    0
    #15
    This is what I have in mine:


    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress
     
    Emperor, Oct 1, 2007 IP
  16. ready2work

    ready2work Guest

    Best Answers:
    0
    #16
    Wow...wow!!!

    Thank you very much Emperor. I just copied what you gave me and appended it in the .htaccess file. IT WORKS NOW!

    Thanks a lot!!!

    (I thank others too for taking initiative to help me in this....Good Day!)
     
    ready2work, Oct 1, 2007 IP
  17. Emperor

    Emperor Guest

    Messages:
    4,822
    Likes Received:
    180
    Best Answers:
    0
    Trophy Points:
    0
    #17
    No prob, have a nice day :D
     
    Emperor, Oct 2, 2007 IP
  18. thegoogler

    thegoogler Peon

    Messages:
    1
    Likes Received:
    0
    Best Answers:
    0
    Trophy Points:
    0
    #18
    Hey Jackass,

    Just wanted to come here from the future let you know that I got here via google. This is the first result for this topic. Your post is useless and actually damaging to people looking for the result.

    Sincerely,

    Dr. Tim Gofuckyourself, Attorney at Law
     
    thegoogler, Sep 13, 2012 IP
  19. HackerMan

    HackerMan Peon

    Messages:
    1
    Likes Received:
    0
    Best Answers:
    0
    Trophy Points:
    1
    #19
    There is nothing you have to work with WordPress, it purely a hosting thing.
    Steps to resolve.

    1) Make sure your .htaccess is existing in your WordPress root folder
    2) If then 100%, it is a hosting issue. So you have to contact hosting support
    3) Mine was digitalocean server, so I cleared it myself

    Edited the file /etc/apache2/sites-enabled/000-default.conf

    Added this line after DocumentRoot /var/www/html

    <Directory /var/www/html>
    AllowOverride All
    </Directory>

    Restart your apache server

    Note: /var/www/html will be your docuement root
     
    HackerMan, Oct 5, 2016 IP