1. Advertising
    y u no do it?

    Advertising (learn more)

    Advertise virtually anything here, with CPM banner ads, CPM email ads and CPC contextual links. You can target relevant areas of the site and show ads based on geographical location of the user if you wish.

    Starts at just $1 per CPM or $0.10 per CPC.

how to increase limit of file attachments size in vbulletin

Discussion in 'vBulletin' started by sajal786, Dec 17, 2011.

  1. #1
    i have vbulletin forum and its have some problem that it cant attach file more than 5 mb. i increase limit many times from the admin mode but it doesnt work.
    i saw many forum they attached files of size 30 to 40 mb.
    plz help me out
    SEMrush
     
    sajal786, Dec 17, 2011 IP
    SEMrush
  2. |-:Bharat:-|

    |-:Bharat:-| Active Member

    Messages:
    179
    Likes Received:
    3
    Best Answers:
    0
    Trophy Points:
    95
    #2
    In addition to the vB settings, the allowed size of the attachments depends on the PHP and MySQL configuration. You may need to check and change the upload size for both PHP and for MySQL. Note, you'll need to have root access to the server to do this (or have your host do it.) Make these changes to php.ini:

    upload_max_filesize = xM

    ..and my.cnf (or my.ini for Windows systems)

    set-variable=max_allowed_packet=xM

    Change it to the size ('x') you want in Megabytes. Restart the webserver and MySQL after making these changes.

    Note: Do NOT use MB, just M for the megabytes setting.

    You may also need to increase the memory_limit, max_execution_time and max_input_time variables in php.ini.
     
    |-:Bharat:-|, Dec 18, 2011 IP
  3. AnthonyG

    AnthonyG Active Member

    Messages:
    114
    Likes Received:
    3
    Best Answers:
    2
    Trophy Points:
    85
    #3
    You must also set this post_max_size = ( 1M higher ) than upload_max_filesize = ie....

    upload_max_filesize = 50M
    post_max_size = 51M

    The setting " max_allowed_packet = " doesnt need to be changed if its only in the [mysqld] section of your my.cnf, it may cause issues if its set in the [client] section of my.cnf
     
    AnthonyG, Dec 20, 2011 IP