1. Advertising
    y u no do it?

    Advertising (learn more)

    Advertise virtually anything here, with CPM banner ads, CPM email ads and CPC contextual links. You can target relevant areas of the site and show ads based on geographical location of the user if you wish.

    Starts at just $1 per CPM or $0.10 per CPC.

Google or robots.txt problem

Discussion in 'robots.txt' started by macau2009, Feb 19, 2018.

  1. #1
    When I use google to search my site, it shows my link but it is without any information under the link. I check the robots.txt in my home directory, I saw something like this.

    User-agent: *
    Disallow: /wp-admin/
    Allow: /wp-admin/admin-ajax.php

    Sitemap: http://rcjeep.com/sitemap.xml

    Can you see any problem?
    SEMrush
    Carlos
     
    macau2009, Feb 19, 2018 IP
    SEMrush
  2. qwikad.com

    qwikad.com Illustrious Member Affiliate Manager

    Messages:
    5,477
    Likes Received:
    1,020
    Best Answers:
    19
    Trophy Points:
    400
    #2
    Your sitemap is fine. Your site doesn't have a meta description after the <head>. You need to add something like:

    <meta name="description" content="Rc Jeep, a place for model rc jeep mechanics">

    You can change that description to whatever.
     
    qwikad.com, Feb 19, 2018 IP
  3. macau2009

    macau2009 Active Member

    Messages:
    279
    Likes Received:
    2
    Best Answers:
    0
    Trophy Points:
    55
    #3
    Thanks


     
    macau2009, Feb 19, 2018 IP
  4. Sumit_Singh

    Sumit_Singh Active Member

    Messages:
    371
    Likes Received:
    20
    Best Answers:
    2
    Trophy Points:
    65
    #4
    Hi macau
    The problem is still there, the description part is not shown by the Google if I searched for your website on Google.
    Your Website is on WordPress platform, try this, LogIn to your WordPress account, go to Settings then go to the privacy option and set it to the public to make it visible for everyone and indexed by the SE.
    Hope this will help you.
     
    Sumit_Singh, Feb 19, 2018 IP
  5. Adi Bitar

    Adi Bitar Member

    Messages:
    40
    Likes Received:
    0
    Best Answers:
    0
    Trophy Points:
    36
    #5
    Yes, absolutely you are correct.
     
    Adi Bitar, Feb 19, 2018 IP
  6. Sumit_Singh

    Sumit_Singh Active Member

    Messages:
    371
    Likes Received:
    20
    Best Answers:
    2
    Trophy Points:
    65
    #6
    Let's see if this will help the OP or not to get rid of the problem.
     
    Sumit_Singh, Feb 19, 2018 IP
  7. qwikad.com

    qwikad.com Illustrious Member Affiliate Manager

    Messages:
    5,477
    Likes Received:
    1,020
    Best Answers:
    19
    Trophy Points:
    400
    #7
    @macau2009 Your site is still not indexed and there's no description showing. However, your site does show like it is shown here:

    https://support.google.com/webmasters/answer/7489871?hl=en

    Which tells me that it is possible that your robot.txt file is blocking Googlebot. Somehow the Disallow: /wp-admin/ is blocking the entire site. Put this in your robot.txt file instead and give it a couple days to let Googlebot crawl your site:

    
    User-agent: *
    Disallow:
    
    Code (markup):
     
    qwikad.com, Feb 21, 2018 IP