1. Advertising
    y u no do it?

    Advertising (learn more)

    Advertise virtually anything here, with CPM banner ads, CPM email ads and CPC contextual links. You can target relevant areas of the site and show ads based on geographical location of the user if you wish.

    Starts at just $1 per CPM or $0.10 per CPC.

DB transfer not working for my forum. Help!

Discussion in 'Databases' started by tdotman, Nov 23, 2014.

  1. #1
    Hi there, so I had an instance of Simple Machines Forum ( An online community) builder set up. It had board categories, 300 members and hundreds of posts. I tried to change the theme and lost everything. I then scratched/removed all of the files and reinstalled a new version of the message board. Different version 2.09 vs 1.1.1. which is what I had earlier. I want to know how to import all of my former DB info(posts, post categories, board categories, members) into the new forum so it is populated with it.

    Thanks
    SEMrush
    Omar
     
    tdotman, Nov 23, 2014 IP
    SEMrush
  2. billzo

    billzo Well-Known Member

    Messages:
    961
    Likes Received:
    278
    Best Answers:
    15
    Trophy Points:
    113
    #2
    Did you save a backup copy of the forum SQL before making changes? If so, you should have no problem re-importing the SQL through phpMyAdmin or some other database front-end. If you do not have a backup copy, then check with your web host to see if you can get a copy from their backups. If you are lucky (and act fast), you may be able to.

    As for the upgrade you want to do, I think it would be best for you to re-install the version of the board you were using then upgrade after everything is set up and working right. The upgrade script has to make some changes, and probably changes to the database, so you are best to set up everything as you had it then make the upgrade.
     
    billzo, Nov 23, 2014 IP
  3. tdotman

    tdotman Member

    Messages:
    8
    Likes Received:
    0
    Best Answers:
    0
    Trophy Points:
    31
    #3
    I did save the original DB and export it.
    So scratch my first post. I called Go Daddy and they are looking into something. Here is the new situation.
    (I did try importing the SQL data and it did not populate my new board FYI)
    So I created a new install and when it came to the install wizard prompting me for the SQL info, I entered the desired db's infowhich is what I was supposed to do and got a "can't connect" . It is a GoDaddy issue(They are looking into it and so hopefully if it works, then I'll have my board back online. keep you posted.
     
    tdotman, Nov 23, 2014 IP
  4. billzo

    billzo Well-Known Member

    Messages:
    961
    Likes Received:
    278
    Best Answers:
    15
    Trophy Points:
    113
    #4
    You did ensure that the forum's configuration file contained the right server name and credentials? Just thought I would ask.

    Just keep in mind that if your database is version 1.1.1 and your SMF files are not, you may run into additional problems.
     
    billzo, Nov 23, 2014 IP
  5. tdotman

    tdotman Member

    Messages:
    8
    Likes Received:
    0
    Best Answers:
    0
    Trophy Points:
    31
    #5
    Having GoDaddy look into an even more remedial issue. will keep you updated as this may help others. Thanks.
     
    tdotman, Nov 23, 2014 IP
  6. Prashant J

    Prashant J Member

    Messages:
    12
    Likes Received:
    0
    Best Answers:
    0
    Trophy Points:
    31
    #6
    Dear tdotman ,

    After restoring the database using phpmydmin or other Mysql Client please try resetting the database user name and password . Hope this Helps :)
     
    Prashant J, Dec 6, 2014 IP