1. Advertising
    y u no do it?

    Advertising (learn more)

    Advertise virtually anything here, with CPM banner ads, CPM email ads and CPC contextual links. You can target relevant areas of the site and show ads based on geographical location of the user if you wish.

    Starts at just $1 per CPM or $0.10 per CPC.

CDN & Caching Blocking Email Automation

Discussion in 'Site & Server Administration' started by monkeywisdom, Aug 6, 2020.

  1. #1
    I’m using Groundhogg with Wordpress. I have caching through Litespeed’s plugin, Cloudflare (DNS records are only in my CPanel), and the server itself. All three, together and individually, block emails being sent using Groundhogg. Groundhogg is an email marketing and automation tool. Users cannot get through the basic opt-in funnel. They’ll submit the form and get the confirmation email. When they click the confirm link, they’re oddly taken to a “manage your preferences” page instead of a “you are confirmed” page. They do not receive the welcome email that delivers the lead magnet.

    My host is Hostinger, which is a Cloudflare partner. You manage your DNS in Hostinger, not Cloudflare. There are no orange/gray clouds to turn on or off.

    Groundhogg’s CEO mentioned turning off caching for WP’s Rest API and otherwise said it should work with Litespeed, WP, and Cloudflare just fine. What am I missing?

    Thanks.
    SEMrush
     
    monkeywisdom, Aug 6, 2020 IP
    SEMrush
  2. knewedge

    knewedge Active Member

    Messages:
    37
    Likes Received:
    0
    Best Answers:
    0
    Trophy Points:
    61
    #2
    I would at least try clearing all your caching services, and plugins to see if that helps or not.

    Also, you might try enabling debugging in WordPress. That might give you an error message that you can have Groundhogg look into.
     
    knewedge, Sep 8, 2020 IP
  3. monkeywisdom

    monkeywisdom Member

    Messages:
    5
    Likes Received:
    0
    Best Answers:
    0
    Trophy Points:
    36
    #3
    I cleared all caches a bazillion times at every step. I ended up disabling server level caching and adding new page rules in Cloudflare. There's something else in LSCache I disabled as well. It's working, but with a 2-minute delay from SES.
     
    monkeywisdom, Sep 8, 2020 IP