1. Advertising
    y u no do it?

    Advertising (learn more)

    Advertise virtually anything here, with CPM banner ads, CPM email ads and CPC contextual links. You can target relevant areas of the site and show ads based on geographical location of the user if you wish.

    Starts at just $1 per CPM or $0.10 per CPC.
  2. Better Analytics for WordPress Get It Free

BUG with embedded Flash ???

Discussion in 'AdSense' started by juggernart, Nov 29, 2004.

  1. #1
    Hi.
    I encountered a weird Adsense behaviour (BUG?) with some of my pages:
    On these pages I have two Adsense blocks and one Flash-SWF embedded content. The SWFs are embedded with the standard correct Object/Embed code.
    The problem is that on these pages the AdSense scripts don't seem to work right! Most times there's only a white empty block on one or both places were the AdSense should be. First time one of the pages (see below) is opened it is shown correct, but if it is reloaded, or another of the pages is opened, the problem comes up.
    It happens for me on IE 6/WIN 2000 and on IE 5/MAC OSX. With Safari on Mac OSX the pages and AdSense content show allways correct!
    On Mac IE 5 it's even more weird. There it often happens, that the AdSense blocks show up with the "Ads by Gooogle" header and the respective border color, but no text appears, or the text is broken!
    I have defined a alternative AdSense color and also have tried an alternative URL with no luck.

    I came to the conclusion that the Flash content somehow stops the scripts by running correct. If I remove the embedded Flash, both Ads show correct.

    I contacted Google about it today ...waiting for reply

    Here are the links (can't post live links yet, sorry):
    http://www.juggernart.com/games/aqua_blocks/index.html
    http://www.juggernart.com/games/celebrity_puzzler/index.html
    http://www.juggernart.com/games/faelschung/index.html
    http://www.juggernart.com/games/five_a_row/index.html
    http://www.juggernart.com/games/LunarCommand/index.html
    http://www.juggernart.com/games/XmasXpress/index.html

    This is the "parent" page with two AdSense blocks and no Flash, working correct:
    http://www.juggernart.com/games/index.html

    Can you please check if it happens for you too, and what browser and system? Thanks.
     
    juggernart, Nov 29, 2004 IP
  2. TwisterMc

    TwisterMc Mac Guru

    Messages:
    972
    Likes Received:
    13
    Best Answers:
    0
    Trophy Points:
    0
    #2
    My guess would be that the pages that don't show ads is because there are no ads that match the few words you have on your page. Look at your XmasXpress page, it's full of ads. That's because it's the Christmas season and lots of people want to target any Christmas sites. I'd say add some more descriptive text on the pages and you may actually get ads.
     
    TwisterMc, Nov 29, 2004 IP
  3. juggernart

    juggernart Active Member

    Messages:
    84
    Likes Received:
    4
    Best Answers:
    0
    Trophy Points:
    50
    #3
    Don't think so.
    The problem is NOT that there is no content to show (In Safari both AdSense boxes are most times full), the problem is, that it shows a white empty box where it should show at least the alternative color (the background color).

    As I said, removing the SWF embedding from the pages, both AdSense blocks show up right.

    Also look at the following two screenshots I made (Mac OSX IE5). I wouldn't say that this is the normal AdSense behaviour if there are no ads to show.
     

    Attached Files:

    juggernart, Nov 29, 2004 IP
  4. TwisterMc

    TwisterMc Mac Guru

    Messages:
    972
    Likes Received:
    13
    Best Answers:
    0
    Trophy Points:
    0
    #4
    Well there goes my theory.
     
    TwisterMc, Nov 29, 2004 IP