1. Advertising
    y u no do it?

    Advertising (learn more)

    Advertise virtually anything here, with CPM banner ads, CPM email ads and CPC contextual links. You can target relevant areas of the site and show ads based on geographical location of the user if you wish.

    Starts at just $1 per CPM or $0.10 per CPC.

Better Analytics - XenForo - Spike in SPAM bots/crawlers

Discussion in 'Better Analytics' started by kaieivindm, May 7, 2017.

  1. #1
    Hi,

    So I've been using the free Version of Better Analytics for XenForo quite a while. Has been working like a charm, but decided I needed some more functions. So I purchased the Product yesterday.
    SEMrush
    Since I wanted most out of the tool, I checked off everything I needed in the Xenforo settings panel. About 1 minute after installation and saved settings, I got like 120 sessions from the US, France and Brazil primarily and no real users. Just spam, crawlers, bots and whatnot.

    So I checked the Bot filtering check Box in GA, which reduced the traffic logged in GA quite a lot. But I still get tons of these crawlers on my site today, which I did not even see With the free Version.

    So basically, my question is why? Is it because I track more traffic now?

    Bonus question, If I use IP Block Manager in CPANEL, for ip-ranges, will those still be tracked in GA?
     
    kaieivindm, May 7, 2017 IP
    SEMrush
  2. digitalpoint

    digitalpoint Overlord of no one Staff

    Messages:
    38,192
    Likes Received:
    2,584
    Best Answers:
    457
    Trophy Points:
    710
    Digital Goods:
    29
    #2
    You are probably just logging a bunch of traffic that isn't calling itself out as being a (popular) spider and it's also not executing JavaScript.

    The "Track Users With Analytics Blockers" setting has a lot of info about using it under the setting itself. The other setting you might want to consider not using is logging of attachment views.
     
    digitalpoint, May 8, 2017 IP
  3. kaieivindm

    kaieivindm Greenhorn

    Messages:
    3
    Likes Received:
    1
    Best Answers:
    0
    Trophy Points:
    13
    #3
    Correct, tons of traffic, but not executing any JS at all.

    Maybe its due to my non-English Language, but if I understand the text correctly, I should really only use "Only users logged in" on "Track users With Analytics Blockers"?
    I have it set to all now. So makes sense I Guess.
     
    kaieivindm, May 8, 2017 IP
  4. digitalpoint

    digitalpoint Overlord of no one Staff

    Messages:
    38,192
    Likes Received:
    2,584
    Best Answers:
    457
    Trophy Points:
    710
    Digital Goods:
    29
    #4
    Ya, thats going to be the best setting in most cases. Basically then you will have users logged that are excuting JavaScript (most legit users) plus also logged in users that don't run JS or are blocking analytics (a bot isn't going to be logged into a user account).
     
    digitalpoint, May 8, 2017 IP
  5. kaieivindm

    kaieivindm Greenhorn

    Messages:
    3
    Likes Received:
    1
    Best Answers:
    0
    Trophy Points:
    13
    #5
    To be honest, I've noticed the drop in 10 Seconds after I changed the settings. And its been OK since the change.

    Thanks for the help, and a great plugin :)
     
    kaieivindm, May 8, 2017 IP
    digitalpoint likes this.