1. Advertising
    y u no do it?

    Advertising (learn more)

    Advertise virtually anything here, with CPM banner ads, CPM email ads and CPC contextual links. You can target relevant areas of the site and show ads based on geographical location of the user if you wish.

    Starts at just $1 per CPM or $0.10 per CPC.

5xx-errors!!!

Discussion in 'Google Sitemaps' started by MrWize, May 20, 2006.

  1. #1
    Hi,

    on my site www.dogindex.eu/ i get a lot of 5xx-errors. When I check the pages by clicking all links reported they works well. Check with "header tools" and I get 200 OK requests. The page has an UTF-8 encoding, but googlesitemap reports US-ASCII encoding.

    the sitemap is located here - www.dogindex.eu/sitemap.aspx -
    SEMrush
    Anyone else that has the same problem? I think I will remove the sitemap since the mainpage is already indexed ... and this 5xx-errors are holding the indexing of all other pages, and even making the mainpage searchable in google

    The site ranks on first page in MSN, all pages are indexed in MSN .... just Google Sitemap that "fu**s" everything up ... i suspect :(

    any tips?

    cya,
    /PatrikB
     
    MrWize, May 20, 2006 IP
    SEMrush
  2. Evoleto

    Evoleto Well-Known Member

    Messages:
    253
    Likes Received:
    7
    Best Answers:
    0
    Trophy Points:
    108
    #2
    Removing the sitemap won't affect the response code your server sends (5xx).
     
    Evoleto, May 20, 2006 IP
  3. MrWize

    MrWize Peon

    Messages:
    54
    Likes Received:
    1
    Best Answers:
    0
    Trophy Points:
    0
    #3
    But ... it just appear for google ... every time I check them at different times on the day, even in the middle of the night (as it is now in Sweden), when google bot almost always check it out, it works and give 200 OK requests ... but ... thats not the case for google. and they also get the encoding wrong :(

    cya,
    /PatrikB
     
    MrWize, May 20, 2006 IP
  4. Evoleto

    Evoleto Well-Known Member

    Messages:
    253
    Likes Received:
    7
    Best Answers:
    0
    Trophy Points:
    108
    #4
    Googlebot is a bit hardheaded with encoding. I had problems myself and after trying more "tricks" seemed it work, but I cannot determine which is right solution.

    As about the server errors, are you totally sure it returns none? The best thing to do would be to download the httpd logs and analyze them if you have access to them. I thought the same thing for a site I managed, and after some serious debugging I found two conflicting components running in certain time intervals and were gerating 500 error to Googlebot.
     
    Evoleto, May 20, 2006 IP
  5. MrWize

    MrWize Peon

    Messages:
    54
    Likes Received:
    1
    Best Answers:
    0
    Trophy Points:
    0
    #5
    It is ONLY reporting 500-errors when googlebot arrives and try to get a sub-page (not the mainpage, wich is OK).

    I can have googlebot visiting, reportin a 500-error, the second after when a "normal users" try to get the exact same page it is reporting 200 OK ... very funny .... not .... and very hard to debug when everything is working OK except for googlebot.

    cya,
    /PatrikB
     
    MrWize, May 21, 2006 IP